Nath's Blog

Life. Through the eyes of Nathan Coad.

VirtualCentre 2.0 and Linux

First of all I should point out that I’m still alive, although I haven’t updated this blog for quite some time.

The main point of this entry is to highlight the fact that I’ve got a console for virtual machines running under linux, with VirtualCentre 2.0 (or virtualcenter for you americans).

The MUI (the web interface) has a console page for each of the virtual machines, but it requires a plugin. Under windows and IE, this is an ActiveX plugin. Under mozilla/firefox, there is a plugin provided called vmware-mks.xpi. It installs and runs fine under windows, but when trying to install it on Firefox 1.5.0.7 on my Ubuntu 6.06 install, it fails with a message along the lines of “Failed to install vmware-mks.xpi Because: cancelled.” Closing my browser, disabling plugins etc had no effect.

I ultimately got this working by downloading the xpi, changing the file extension to .zip, unzipping it, and moving the resulting files to /usr/lib/mozilla-firefox/plugins. I also put a copy in /usr/lib/mozilla/plugins just in case.

And now it works! I get a functional console with Virtual Centre 2.0 under linux. It seems there is little need for a proper client, unless theres a lot of functionality that I’m missing (which I’m sure there probably is – VMotion comes to mind).

Thats all for now, time to go home 😉

4 Comments

  1. <p>I&#039;ve run into the same problem. However I&#039;m running ESX 3.0.1 as par of VI3.</p><p>I downloaded the vmware-mks.xpi file, changed the file extention to .zip, unzipped the folder and copied the resulting files…<br />
    remotemks<br />
    viewer<br />
    libcrypto.so.0.9.7<br />
    libssl.so.0.9.7<br />
    install.js<br />
    libmks.so<br />
    xpcomIVMControl.xpt<br />
    …to /usr/lib/firefox-1.5.0.9/plugins however even after restarting my browser it doesn&#039;t work</p><p>Do you have any idea as to what else I can do?</p>

  2. On several SUSE 10.1 boxes with Firefox 2.0.0.14, I installed libexpat and libcrypto (from compat-expat1.1.95.8060i586.rpm downloaded from http://ftp.opensuse.org) and manually extracted the .xpi file to /usr/lib/firefox/plugins to get it to work (after spending 1.5 hours on the phone with VMware). Even after installing libexpat/libcrypto, the plugin installation fails. The only way to get it to work is to manually extract it.

  3. For x86_64 Debian ldd get many unresolved links:

    $ ldd libmks.so
    libX11.so.6 => not found
    libXext.so.6 => not found
    libexpat.so.0 => not found
    libfontconfig.so.1 => not found
    libfreetype.so.6 => not found
    …..
    libglib-2.0.so.0 => not found
    libgtk-x11-2.0.so.0 => not found

    This lib not present in /lib32 and can not be there anyway.
    So Linux mast be 32-bit.

  4. Thank you. It works and it was a very useful tip.

Leave a Reply

Your email address will not be published.

*

© 2017 Nath's Blog

Theme by Anders NorenUp ↑